Fixed Service
Resolved
Identified
We found the issue, deploying a solution.
Investigating
We're investigating why transactions are just dropped from the queue.